Troubleshooting
Problem
Sometimes it is the case that inspite of having all the configuration correct for search index, we still observe the error as : "Could not find active search index." Also here the Index is created fine and it is in ACTIVE status when checked out in SBC.
Symptom
If checked in the logs, it is observed that the category domain in such case is equal to NULL.
YCMSearchCatalogIndexManager normally creates a map which associates the SearchIndexKey with the organization code. These are put in during loadSearchResultsForIndex() call which in turn is called. Once the search index cache (in memory) needs to be refreshed.
Cause
In a case when Search Index is active and still you are not able to browse through the product then it appears that the cache is not refreshed after build.
Resolving The Problem
Disabling the caching for YFS_SEARCH_INDEX solves the issue.
Add the below property to customer_overrides.properties file, restart the app server, and try again:
YFS_SEARCH_INDEX.enabled=false
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Document Information
Modified date:
16 June 2018
UID
swg21963560