IBM Support

findInventory call does not return inventory for supersession items in Sterling Order Management

Troubleshooting


Problem

findInventory call does not return inventory for substitute items  

Cause

This is a known issue in v9.2 and is fixed in v9.4

Environment

1. Create two items, Item1 and Item2 such that Item2 is associated as a supersession of Item1.
2. Adjust inventory for Item2 at any node say Node1. No inventory should be available for Item1.
3. For Node1 make sure that Is Substitution Allowed flag is checked.
4. Create a DG with Node1 and add it in the sourcing rule or add Node1 directly.
5. Make sure that the sourcing rule has only 1 template which has the above DG/Node.
6. Call findInventory API with the below input:

<Promise DistanceToConsider="1000" FulfillmentType="PRODUCT_SOURCING"
IsSubstitutionAllowed="Y" OrganizationCode="DEFAULT"
RadiusInMiles="1000">
<PromiseLines>
<PromiseLine ItemID="Item1" RequiredQty="999999999999" UnitOfMeasure="EACH"/>
</PromiseLines>
<ShipToAddress Country="US" ZipCode="12345"/>
</Promise>

Item is shown as unavailable and no assignments are formed.

Diagnosing The Problem

The issue occurs specifically when the sourcing rule has just one template.

Resolving The Problem

As a workaround, you can  check the "allow procurement" check box  or add another template in the sourcing rule with a blank DG or any ShipNode.

[{"Product":{"code":"SS6PEW","label":"IBM Sterling Order Management"},"Business Unit":{"code":"BU048","label":"IBM Software"},"Component":"Distributed Order Management","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"9.2","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21962457