Troubleshooting
Problem
User launches main Controller client (CCR.EXE). User clicks the green 'X' (to launch the Controller Excel link). An error appears.
Symptom
Error Launching menu item "Controller Link"
[Details] [OK]
Error Details
Unable to cast COM object of type
'Microsoft.Office.Interop.Excel.ApplicationClass' to interface type 'Microsoft.Office.Interop.Excel._Application'. This operation failed because the QueryInterface call on the COM component for the interface with IIF '{000208D5-0000-0000-C000-000000000046}' failed due to the following error: Library not registered. (Exception from HRESULT: 0x8002801D (TYPE_E_LIBNOTREGISTERED)).
Cause
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
NOTE: It is important that you check the error message carefully. This Technote relates only to the scenario where the error contains: Library not registered ... TYPE_E_LIBNOTREGISTERED
- TIP: If your error is similar, but instead contains 'DError loading type library/DLL … HRESULT: 0x80029C4A (TYPE_E_CANTLOADLIBRARY' then see separate IBM Technotes (for example #548203)
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
In general, the cause of 'Library not registered ... TYPE_E_LIBNOTREGISTERED' errors is that the client device (where the Controller client is running) has corrupt/invalid Microsoft Office Primary Interop Assemblies installed/registered.
- Microsoft Office Primary Interop Assemblies are components that are registered (inside the Windows registry) as part of a default MS Office installation
- These third-party (Microsoft) interoperability assemblies are used by Controller to trigger Excel tasks.
There are several known scenarios which can trigger MS Office interop assembly corruption:
Scenario #1 - Missing third party (Microsoft) components on client device.
- Specifically, missing Microsoft Office component " .NET Programmability Support"
- TIP: ".NET Programmability Support" is installed as part of a 'default' MS Office installation. However, the 'bad' PC may have had a customised MS Office install that did not install this optional component.
Scenario #2 - An incompatible version of Skype for Business has been installed on the client device
- This has created a mixture of Microsoft Office 'types' of installation on the client device (for example, different types of registry key entries), and this is confusing Controller.
Scenario #3 - Corruption in the registry of the client device
- In one real-life case, this was triggered by:
- (a) uninstalling Office 2013
- (b) installing Office 365
Resolving The Problem
Scenario #1
Install all the optional components of Microsoft Office, on the client device.
Scenario #2
Install all the optional components of Microsoft Office, on the client device.
Scenario #2
Uninstall Skype.
- For more details, see separate IBM Technote #1992629.
Scenario #3
Investigate and fix corruption in the registry. For example, perform a Microsoft Office 'Repair.
Investigate and fix corruption in the registry. For example, perform a Microsoft Office 'Repair.
- For more details, see separate IBM Technote #6332207.
Related Information
[{"Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"ARM Category":[{"code":"a8m0z000000Gmx2AAC","label":"Error"}],"ARM Case Number":"TS004126739","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Version(s)"}]
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Document Information
Modified date:
11 September 2020
UID
swg21962087