IBM Support

Unable to switch between Information Server client versions when using Datastage Multi-Client Manager

Troubleshooting


Problem

When you attempt to switch from versions in the Datastage Multi-Client Manager, receive the following error: "Problem occured while trying to set the version. No more information available"

Symptom

Open DataStage Multi-Client Manager


Select the version and click Select:

Cause

Either DataStage Clients were not installed in version order or the newest version was installed under a directory which already contained other versions of DataStage Clients.

e.g.

Version 8.7 was installed under:
C:\IBM\InformationServer

Subsequent versions were installed under:
C:\IBM\InformationServer\Datastage8.7
C:\IBM\InformationServer\Datastage9.1

The Multi-Client Manager must look for ClientSwitcherService.exe from the latest client version.

Typically this is under <Installation_Path>\MCM\ClientSwitcherService.exe

Another cause could be that an installation of a new DataStage client version or patch was completed recently.

Diagnosing The Problem

Use below technote in order to set up and collect the MCM trace:


http://www-01.ibm.com/support/docview.wss?uid=swg21689464

From mcm_log.txt error observed was:

**************** MCM Log Start: 2015-06-18 10:23:16 ****************
2015-06-18 10:23:16 INFO : MCM Client version: '9.1.2.0'
2015-06-18 10:23:16 INFO : MCM Client path: 'C:\IBM\InformationServer\Datastage9.1\MCM\MultiClientManager.exe'
2015-06-18 10:23:16 INFO : MCM Client user: 'vikaskum'
2015-06-18 10:23:16 ERROR: The version of the DataStage Multi-Client Manager service (ClientSwitcherService.exe, version 8.7.0.0) differs from the version of this tool (9.1.2.0). Please ensure the correct version of the service is installed and running.

**************** MCM Log End: 2015-06-18 10:23:16 ******************

Resolving The Problem

There are several possible ways to resolve this problem:

1) Un-install all DataStage Clients and re-install in version order, starting with the oldest version, finishing with the newest version.

2) From the Windows Client machine, run Regedit tool and change below Windows registries to point to the ClientSwitcherService.exe of the latest version of DataStage Client installed.

HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\services\ASCLCSSrv
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\services\ASCLCSSrv
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\ASCLCSSrv

After that, launch Windows Services tool and restart the DataStage Multi-Client service.

3) Reboot the machine after a new version of DataStage client or patch is installed.

[{"Product":{"code":"SSVSEF","label":"IBM InfoSphere DataStage"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"9.1;8.7;11.3.1.0;11.3","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
16 June 2018

UID

swg21961326