IBM Support

Slow logins into Web Call Center for Commerce

Troubleshooting


Problem

Attempts to login to IBM Web Call Center for Commerce (WCC) takes more time than expected.

Cause

The page loading time was affected due to the large size of the javascript files being sent across in the network traffic

Diagnosing The Problem

Few javascript files like scDojoIsccs.js were taking long time to load and adding to the delay. The file scDojoIsccs.js was 7MB of size.

Resolving The Problem

To resolve the issue, implement data compression on the web server to reduce the data packet size.
For example
The size of the scDojoIsccs.js file was compressed from 7MB to around 1MB. This in will turn reduce network traffic and decrease the page load time.

Every web server (not application server) has its own configuration to enable data compression.



See also: Enabling data compression on an IBM HTTP Server

With data compression, a very significant improvement was noticed in the time taken to log in into Web Call center

[{"Product":{"code":"SSYLSL","label":"IBM Call Center for Commerce"},"Business Unit":{"code":"BU048","label":"IBM Software"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF034","label":"Windows Mobile"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"9.4;9.3","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}},{"Product":{"code":"SS6PEW","label":"IBM Sterling Order Management"},"Business Unit":{"code":"BU048","label":"IBM Software"},"Component":"Sterling Call Center and Store","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21696713