Troubleshooting
Problem
After upgrading IBM Daeja ViewONE Professional from 4.1.1 to 4.1.2 users see error: Incorrect XSL version, annotations may not display correctly
Symptom
Just before the requested image displays, users see a pop-up:
*****Incorrect XSL version, annotations may not display correctly*****
Minimum XSL version: 400020
But found version: 400018
Once clicking OK, the image is properly displayed to the end user
Cause
annot.xsl was not updated on the web server after the Daeja Viewer was updated.
Environment
Stand alone custom web application with Daeja ViewONE Pro integrated. Images stored on a FileNet Image Services server
Diagnosing The Problem
annot.xsl is only required when Daeja is communicating to a FileNet repository such as IBM FileNet Content Engine or Image Services. Their is no required location for annot.xsl, but the older version must be manually replace with the new version. It's normally integrated with the custom app or located on the application or http web server where the custom app is deployed.
Validate the Minimum XSL version from the error message is the same as XSLVERSION the annot.xsl found in the install location of the upgraded Daeja ViewONE Pro. If the XSLVERSION is correct, that indicates there is annot.xsl in the environment that includes the found version reported in the error message.
Resolving The Problem
Search for and replace the older version of annot.xsl:
- Search all your application and http servers that interface with the Daeja ViewONE integrated custom application for older versions of annot.xsl
- Replace the older version of annot.xsl with the newer version installed with the Daeja upgrade. Default install location: c:\Program Files x86\.IBM\Daeja ViewONE\client\annot.xsl
- Restart the custom application, clearing cache as needed.
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Document Information
Modified date:
28 January 2021
UID
swg21696507