Troubleshooting
Problem
Upgrade of server fails and RC 1603 is seen in the db2install.log
Symptom
You may see the following error in the db2install.log:
Command: "C:\Program Files\Tivoli\TSM\db2tmp\ESE\image\setup.exe"
/f /i en /u "C:\Program Files\Tivoli\TSM\db2tmp\db2resp.tmp" /l
"C:\ProgramData\IBM\Installation Manager\logs\native\tsm_logs\db2_install.log"
stdout: stderr: RC: 1603
Cause
In some cases, a third party monitoring utility restarted db2. This can cause the db2 upgrade to fail.
Environment
Server 7.1.1.0 upgraded to 7.1.1.100 on Windows 2012
Resolving The Problem
These errors indicate that DB2 failed to upgrade because the installation was unable to stop the DB2 processes. To solve the problem, complete the following steps:
1. Stop the Tivoli Storage Manager server instance.
2. Verify that all DB2 services are stopped.
3. Re-run the Tivoli Storage Manager upgrade. This will update DB2.
[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Server","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Supported Versions","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]
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Document Information
Modified date:
17 June 2018
UID
swg21694787