IBM Support

Error importing on Guardium aggregator: Failed to merge static tables

Troubleshooting


Problem

Importing data from a 64-bit IBM Infosphere Guardium machine to a 32-bit aggregator or central manager will fail. You can import files from a 32-bit machine on a 64-bit aggregator or CM but not the other way around.

Symptom

In the aggregator's GUI under Guardium Monitor - Aggregation / Archive Log the following error appears each time files from the the 64-bit collector try to import.

    "Failed merging static tables (suffix=conversion_failed)"

Cause

All 64-bit versions of Guardium use a newer major version of MySQL and a 32-bit unit cannot read these tables. This is true even if the 64-bit unit is on a earlier patch level; for instance if a 64-bit collector on GPU 200 exports to a 32-bit aggregator on GPU 300 the process will still fail with this error.

Diagnosing The Problem

Use the CLi fileserver command to view /var/log/guard/agg_copy_table.log and you will find this error.

ERROR 1033 (HY000) at line 1: Table
'./AGG_TMP/MONITOR_VALUES_CHANGED_COLUMN__N__<date data was collected>__<collector name>' was created with a different version of MySQL and cannot be read

The error will appear many times with different table names.

Resolving The Problem

Follow best practice and upgrade to 64-bit machines starting with your aggregators, followed by the collectors. Do not set 64-bit collectors to export to 32-bit aggregators.

[{"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Guardium Central Manager and Aggregator","Platform":[{"code":"PF016","label":"Linux"}],"Version":"9.1","Edition":"All Editions","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21691776