Troubleshooting
Problem
In some cases it is necessary to revert the Fastback server configuration to an previous state. This is usually caused by the current configurations files either being corrupted or missing.
Symptom
The Fastback server may start in limited mode or Fastback Manager may not be able to connect to the Fastback server at all.
Cause
This is usually caused by the current configurations files either being corrupted or missing.
Resolving The Problem
The Fastback server will backup the configuration files daily in the %ProgramData/ALLUSERSPROFILE%/Fastback/server/HistoryLog/ folder. Within this folder are up to 30 folders labeled log1-log30. To determine which folder contains the most recent configuration backup check the state.txt file in the /Fastback/server/ folder. In the file, if it exists, there should be:
LogName = #
The # corresponds to the log folder number so if:
LogName = 13
Then the most recent configuration backup is in:
/Fastback/server/HistoryLog/Log13
Alternatively, the date/timestamp or the files in each folder can be checked to find the most recent backup.
To apply the configuration to the Fastback server perform the following steps:
1. Stop the Fastback server process
2. Copy the contents of the most recent Log# folder to the following locations:
%ProgramData/ALLUSERSPROFILE%/Fastback/server/
%ProgramData/ALLUSERSPROFILE%/Fastback/server/mirror
root of ALL repository volumes
3. Restart the Fastback server
Product Synonym
TSM FSBK FBK FB
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Document Information
Modified date:
17 June 2018
UID
swg21691326