Troubleshooting
Problem
How do I remove a Guardium patch that was uploaded with a bad filename?
Symptom
When attempting to upload a patch that was named incorrectly, a similar error message is displayed on the CLI console when exiting fileserver:
Register patch files in the directory:
12345.111.222.SqlGuard-9.0p1200.tgz.enc
/usr/local/guardium/scripts/install_patch_status.sh: line 256: /var/httpd/tmp/12 345.111.222.SqlGuard-9.0p1200/update_files/patch.reg: No such file or directory
When attempting to list the available patches via CLI, a similar error message will be displayed on the CLI console:
appliance_hostname.domain.com> show system patch available
Please wait - getting information for patch 12345.111.222.SqlGuard-9.0p1200.tgz.enc
gpg: 3DES encrypted data
gpg: encrypted with 1 passphrase
gpg: WARNING: message was not integrity protected
tar: 12345.111.222.SqlGuard-9.0p1200/update_files/patch.reg: Not found in archive
tar: Error exit delayed from previous errors
Extract of file /var/log/guard/patches/var/log/guard/patches/tmp_file has been failed.
Attempting to retrieve the patch information. It may take time. Please wait.
P# Description Version Md5sum Dependencies
1067 Snif update 9.0 5e41d4e304c6059dbb64f5772ccf213d
308 Outer join and meta-data fix 9.0 f8342e5e454f6e50b397c906e77a9bc4 300
ok
appliance_hostname.domain.com>
Cause
Usually when IBM support sends Guardium patches to customers via the PMR system, the PMR number is automatically appended to the patch name. Attempting to upload the patch without renaming it (to remove the PMR number) will lead to the error shown above.
Resolving The Problem
The invalid patch needs to be deleted from /var/log/guard/patches directory.
This requires root access to the Guardium appliance.
Please contact IBM Support for further assistance, and reference this technote in the PMR text.
Related Information
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Document Information
Modified date:
16 June 2018
UID
swg21690833