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Using changeOrder API to apply charge category throws the error Invalid Charge Category and Charge Name Combination in Sterling Order Managment

Troubleshooting


Problem

Attempts to apply charge category through changeOrder API leads to the error error 'YFS:Invalid Charge Category and Charge Name Combination' in IBM Sterling Order Managment

Cause

Charge category does not have a charge name.

Diagnosing The Problem

This validation is done due to the flag Validate Charge name being enabled on the application.
This flag indicates if the system must validate the charge names that are used for an order document that is existing in the system before it proceeds with payment collection.

Resolving The Problem

Steps to resolve::

  1. Launch the application configurator and navigate to DOM - Document Specific-Sales Order-Financial-Financial Rules.


  2. Disable the flag Validate Charge Name.
    Once this is done, you will be able to apply a charge category without a charge name on the order.

[{"Product":{"code":"SS6PEW","label":"IBM Sterling Order Management"},"Business Unit":{"code":"BU048","label":"IBM Software"},"Component":"--","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"9.2;9.1;9.0","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21679485