Troubleshooting
Problem
Attempts to apply charge category through changeOrder API leads to the error error 'YFS:Invalid Charge Category and Charge Name Combination' in IBM Sterling Order Managment
Cause
Charge category does not have a charge name.
Diagnosing The Problem
This validation is done due to the flag Validate Charge name being enabled on the application.
This flag indicates if the system must validate the charge names that are used for an order document that is existing in the system before it proceeds with payment collection.
Resolving The Problem
Steps to resolve::
- Launch the application configurator and navigate to DOM - Document Specific-Sales Order-Financial-Financial Rules.
- Disable the flag Validate Charge Name.
Once this is done, you will be able to apply a charge category without a charge name on the order.
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Document Information
Modified date:
16 June 2018
UID
swg21679485