Troubleshooting
Problem
After you upgrade from IBM Rational Team Concert (RTC) v4.0.1 to v4.0.5, the "CRJAZ2055W" error occurs on the IBM Change and Configuration Manager (CCM) diagnostics page.
Symptom
Steps to reproduce:
- Upgrade your RTC server from version 4.0.1 to 4.0.5
- Go to the CCM diagnostics page at the following site:
https://[your-server-name]:[port]/ccm/admin#action=com.ibm.team.repository.admin.serverDiagnostics
- Use the Run All Diagnostics button
Result: You will get the following error message:
CRJAZ2055W Some indices were missing from the database, and missing indices can negatively impact application performance. To add the missing indices, you should stop your server and execute the -rebuildIndices command in repotools.
as in the following screenshot:
Even if you execute the
-rebuildIndices
command using the repotools
, as the error message suggests, this issue will not be fixed.
Cause
The name of the index table is different in RTC 4.0.5.
If you create a new RTC 4.0.5 database, the index name will be PORT_ORDER_IDX
.
However, if you upgrade from RTC v4.0.1 to v4.0.5, the index name becomes PORT_ORDER_IDX0
.
Resolving The Problem
SOLUTION
Use the following steps to confirm and solve the problem:
- Export the Diagnostics results using the Export Results button on the top-right corner of the Diagnostics page
- Extract all files from the
diagnostics.zip
file and open thecom.ibm.team.repository.service.diagnostics.basic.internal.DBIndexDiagnostic.txt
file. If this file contains theCRJAZ2055W Some indices were missing from the database ... The SQL commands that can be used to add the missing indices are: CREATE INDEX SCM.PORT_ORDER_IDX ON SCM.ACCEPT_QUEUE(WORKSPACE_ID, COMPONENT_ID, ORDER_INDEX)
message, perform Step 3.
- Run the
CREATE INDEX
command from Step 2 on the CCM database. If as a result you get theThe index was not created becase an index "SCM.PORT_ORDER_IDX0" with a matching definition already exists. SQLSTATE=01550
error message, perform Step 4.
- Run the following SQL command on the CCM database:
select * from SYSIBM.SYSINDEXES where TBNAME='ACCEPT_QUEUE'
. If you will get the index table namePORT_ORDER_IDX0
", perform Step 5.
- Rename the table using the SQL command:
rename index SCM.PORT_ORDER_IDX0 to PORT_ORDER_IDX
- Run the
repotools-ccm.sh -rebuildIndices
command after the database changes and rerun all the diagnostics test on the CCM Diagnostic page.
Related Information
Product Synonym
Rational Team Concert
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Document Information
Modified date:
16 June 2018
UID
swg21678193