Troubleshooting
Problem
Attempts to confirm shipment from IBM Store Order Management (SOM) results in to the error YDM00290 : The pack process is not complete for Shipment/Load seen.
Symptom
Steps to reproduce:
- Set up SOM to integrate with Pierbridge for a carrier eg. UPSN.
- Go to Participant Modelling-Parcel carrier preference window of one of the services
For example UPSN Ground and select Shipment Level Integration instead of Package Level Integration.
- Create Order with SCAC as UPSN Ground.
- Schedule and Release Order.
- Login to SOM and Scan shipmentNo in Backroom pick.
- Scan item and then click on Next
Shipment status is now Ready to Pack.
- Go to Pack Shipment and click New Container.
- Scan Item and enter some actual weight. Click on Pack Container.
Container is manifested internally. Once manifested shipment goes to Shipment Packed status and tracking number for the container is generated.
- Now go to confirm shipment in SOM and Select carrier and F7.
- Click Confirm, the following error is thrown
Error : YDM00290 : The pack process is not complete for Shipment/Load seen
Cause
This has been identified as a product defect under APAR IT02663.
Diagnosing The Problem
On Packing Shipment from SOM, internally system adds the packed containers into manifest. If 'Shipment Level Manifest' is configured, then on confirm shipment from SOM the YDM00290 error is thrown.
Resolving The Problem
Store Order Management does not support Shipment Level Manifest in version 9.2.0, 9.2.1, 9.3.
This will be made available in Web Store Version 9.4.
To avoid the error , please use Package Level Integration.
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Document Information
Modified date:
16 June 2018
UID
swg21677395