IBM Support

Installation of IBM HTTP Server V8.0 fails during postinstall configuration

Troubleshooting


Problem

This document addresses an installation issue that can occur during the postinstall configuration of the IBM HTTP Server using the Installation Manager UI on Linux.

Symptom

The installation process for IBM HTTP Server V8.0 completes with a warning message. Although the product installation is complete, one of the post-install configuration actions encounters an error in the Installation Manager log which is located in the /var/ibm/InstallationManager/logs directory. The log is named using the timestamp.xml format, similar to something like 20140725_1114.xml.

Review of the 20140725_1114.xml log indicates that a configuration error occurred during the postinstall process of IBM HTTP Server and instructs the user to look at the logs in the /opt/IBM/HTTPServer/logs/postinstall directory.

A snippet of the error message from the 20140725_1114.xml log is:

<entry num='161' time='1402312502758' elapsed='00:55.81' level='WARNING' thread='Worker-0'>
<logger>com.ibm.cic.common.logging.LogManager</logger> <class>org.eclipse.core.internal.jobs.JobManager</class>
<method>endJob</method>
<message>Configuration errors were detected during the installation. You should view the log files(s) under the /opt/IBM/HTTPServer/logs/postinstall directory to investigate the severity of the errors.
</message>
</entry>

Review of the /postinstall directory logs does not provide a specific cause of the error that occurred during installation.

However you also notice one important detail in the 20140725_1114.xml install log that during the postinstall action the -SERVER_NAME parameter is missing the hostname value (there will be no value after the equals sign).

A snippet from the 20140725_1114.xml log is shown below:

<entry num='190' time='1403721662686' elapsed='05:11.46' level='INFO' thread='Thread-265'>
 <logger>global</logger>
 <class>com.ibm.ws.exec.command.Exec</class>
 <method>exec</method>
 <message>com.ibm.ws.exec.command.Exec
Command: /opt/IBM/HTTPServer/bin/postinstall.sh /opt/IBM/HTTPServer -WS_CMT_CONF_DIR /opt/IBM/HTTPServer/properties/postinstall/ -MASTER_ACTION_REGISTRY
/opt/IBM/HTTPServer/properties/postinstall/masterRegistry.xml -SUB_ACTION_REGISTRY /opt/IBM/HTTPServer/properties/postinstall/cacheRegistry.xml -WS_PI_ACTION_REGISTRY_EXTENSION /opt/IBM/HTTPServer/properties/postinstall/registryExtension.xml -WS_CMT_LOG_HOME /opt/IBM/HTTPServer/logs/postinstall/ -POSTINSTALL_LOG_FILE /opt/IBM/HTTPServer/logs/postinstall/postinstall.log -WS_CMT_HIDE_KEYS ADMIN_AUTH_PASSWORD -IHS_HOME /opt/IBM/HTTPServer -SERVER_ROOT /opt/IBM/HTTPServer -SERVER_NAME = <-- notice the hostname is missing for this parameter
-HTTP_PORT 80 -ADMIN_PORT  -JAVA_DIR /opt/IBM/HTTPServer/java/jre -RUN_SETUPADM false
-CREATE_ADMUSER false -ADMUSER  -ADMGRP  -WEBSERVER_DEFINITION  -CREATE_ADMIN_AUTH false
-ADMIN_AUTH_USER  -ADMIN_AUTH_PASSWORD -IHS_SERVICE_NAME "none" -ADMIN_SERVICE_NAME ""
-CREATE_IHS_SERVICE false -CREATE_ADMIN_SERVICE false
Description : Running post install actions
Return code : 1
StdOut :
StdErr :
</message>
</entry>

Also when trying to start the IBM HTTP Server, the 'apachectl start' command fails with an error:

Example:
[root@testserver ]# /opt/IBM/HTTPServer/bin/apachectl start

/opt/IBM/HTTPServer/bin/apachectl: line 80: @@SERVERROOT@@/bin/httpd: No such file or directory

At this point the IBM HTTP Server will not start.

Cause

One possible cause of the warning in the postinstall log and the " @@SERVERROOT@@/bin/httpd: No such file or directory" error encountered when starting the IBM HTTP Server, is that the Linux machine's /etc/hosts file does not contain an entry for the server hostname and ip address. Only the loopback address is listed in the file as shown below:

Example::

[root@testserver]$ cat /etc/hosts

127.0.0.1 localhost



# special IPv6 addresses
::1 localhost ipv6-localhost ipv6-loopback

Resolving The Problem

To resolve the issue you will need to add a line to the /etc/hosts file that contains the ip address of the server, the fully qualified hostname of the server, and the short hostname of the server.

[root@testserver]$ cat /etc/hosts

9.10.11.12 testserver.ibm.com testserver <--- Add ip address & hostname info



127.0.0.1 localhost

# special IPv6 addresses
::1 localhost ipv6-localhost ipv6-loopback

Use a configuration program associated with the operating system to set the hostname, such as using the "YaST" program on SUSE Linux.

Once you confirm the system's hostname is properly set, you can uninstall and reinstall the IBM HTTP Server product again. If you want to reinstall the IBM HTTP Server into the same directory location as the previous failed installation you will need to make sure any leftover remnants of the failed install have been removed before reinstall of the product.

Start the IBM HTTP Server making sure the error no longer occurs:

[root@testserver] /opt/IBM/HTTPServer/bin/apachectl start
[root@testserver]

More details of this post configuration issue can be found in a related APAR PM69188 at the following url:

- PM69188: INSTALLATION OF IBM HTTP SERVER COMPLETES WITH A WARNING. Failure occurs because the system's hostname is not set:


http://www-01.ibm.com/support/docview.wss?uid=swg1PM69188

Related Information

[{"Product":{"code":"SSEQTP","label":"WebSphere Application Server"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"IBM HTTP Server","Platform":[{"code":"PF016","label":"Linux"}],"Version":"8.5;8.0","Edition":"Base;Network Deployment","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
15 June 2018

UID

swg21676380