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GIM installation of Guardium STAP fails with error 'Can't locate object method "getZone" via package "GIM";

Troubleshooting


Problem

GIM installation of Guardium STAP fails with error 'Can't locate object method "getZone" via package "GIM";

Symptom

Here is an example of the error message from central_logger.log file:


[Tue May 13 13:41:27 2014] -I- Handling KTAP-9.0.0_r57269_1-1400006481
start failure
[Tue May 13 13:41:27 2014] -I- Failure point : start (Can't start KTAP-
9.0.0_r57269_1-1400006481 :
Can't locate object method "getZone" via package "GIM" at
/guardium/gim/modules/KTAP/current/rc line 719, <IN> line 12. (errno:
255)
Failure location : at GIM.pm line 383.).
[Tue May 13 13:41:27 2014] *** IN KTAP RC *** :
(/guardium/gim/modules/KTAP/current/rc stop by_gim) at Tue May 13 13:41:
27 2014
[Tue May 13 13:41:27 2014] -I- KTAP finished execution successfully


STAP may show status of 'IP-PR' from GUI.

Cause

GIM code changes causing incompatibility between major releases. Example - using v8.01 or 8.2 GIM to install or upgrade STAP to v9.x

Environment

GIM STAP

Diagnosing The Problem

Check GIM version and STAP version

Resolving The Problem

Upgrade GIM to same major release level as STAP prior to STAP install or upgrade.

*Note: If the GUI STAP status shows 'IP-PR', perform a 'Reset Clients' from Administration Console->Setup By Module. Once done, upgrade GIM then install or upgrade STAP

[{"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Guardium Database Activity Monitor","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"9.1;9.0;8.2;8.1;8.0.1","Edition":"All Editions","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21673109