Troubleshooting
Problem
Each time you log into the CLI you see errors relating to the /usr/local/guardium/cli/subs_misc.pl script. It says that your last login was Jan 1 1970 and you are forced to reset your password every time you log in to the CLI.
Cause
The file that contains the last login information from the CLI may have been overwritten.
Diagnosing The Problem
The full set of messages you see are:
Use of uninitialized value in string ne at /usr/local/guardium/cli/subs_misc.pl line 3609.
Use of uninitialized value in localtime at /usr/local/guardium/cli/subs_misc.pl line 3610.
Welcome cli - your last login was Thu Jan 1 00:00:00 1970
Use of uninitialized value in numeric ne (!=) at /usr/local/guardium/cli/subs_misc.pl line 3616.
Use of uninitialized value in multiplication (*) at /usr/local/guardium/cli/subs_misc.pl line 3617.
Use of uninitialized value in addition (+) at /usr/local/guardium/cli/subs_misc.pl line 3617.
Your password has expired.
Changing password for 'cli'.
Note: The line numbers may vary depending on the version and patch level of your appliance
Resolving The Problem
IBM technical support will need to access your appliance to resolve this problem. Please open a PMR and reference this technote.
[{"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Not Applicable","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"},{"code":"PF035","label":"z\/OS"}],"Version":"9.1;9.0;8.2","Edition":"All Editions","Line of Business":{"code":"LOB24","label":"Security Software"}}]
Was this topic helpful?
Document Information
Modified date:
16 June 2018
UID
swg21672955