IBM Support

CJDB027E Control Center required tables are not up-to-date at the target DB

Troubleshooting


Problem

Upgraded Sterling Control Center from 5.3.x to 5.4.2.1 and SCC will no longer start.

Symptom

Engine log shows error


CSVC001E Initialization failed. Service: JDBC Service
CJDB027E Control Center required tables are not up-to-date at the target DB

CCTR027E Error Starting Services.
CCTR023E Start Service failed. Service: System:Name=JDBCService,Type=JDBC

CCInstall log shows


INFO DBConn - Missing table list : [V_CX_STATS_LOG, V_QF_STATS_LOG, V_MQ_STATS_LOG, V_AF_STATS_LOG, V_BP_STATS_LOG, V_FG_STATS_LOG, ROLL_UP, CX_STATS_LOG, QF_STATS_LOG, MQ_STATS_LOG, AF_STATS_LOG, BP_STATS_LOG, FG_STATS_LOG]

INFO DBConn - Some of the required tables are missing...

Cause

The upgrade from 5.3.x directly to 5.4.2.1 is not creating the required SCC tables and views in the 5.4.2.1 database.

Diagnosing The Problem

Look for the errors in the Engine log and the CCInstall log.

Resolving The Problem

Have the DBA backup your SCC database tables, then you run configCC and select initialize the DB tables. Then have your DBA copy the data back in from the save tables, then start SCC.

[{"Product":{"code":"SS9GLA","label":"IBM Control Center"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"5.4.2.1;5.3","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
17 December 2019

UID

swg21671050