Troubleshooting
Problem
You have a Guardium appliance that was initially installed at v7. You have upgraded it to v9, however, the health check patch 9997 to upgrade to v9.1 fails. You see the message "ERROR:root partition has less then 1G of free space" in the health check log.
Cause
v7 appliances were built with 3GB space in the root partition. In v9.1 this is no longer enough for the appliance to function correctly.
Environment
Appliances that have been upgraded from v7.
Diagnosing The Problem
In the healthcheck<time_stamp>.log created by the health check patch you see the error:
- ERROR:root partition has less then 1G of free space.
This can occur for other reasons, but if your appliance has been upgraded from v7 the cause above will prevent an upgrade to v9.1.
Resolving The Problem
To set the internal file system with the required partition space you must rebuild the appliance at v9 then upgrade to v9.1. Follow the instructions below:
- 1. Ensure that you are on v9 and take note of your exact patch level using CLI command:
- show system patch installed
2. Take a full data and configuration backup from the GUI:
- Administration Console->Data Management->System Backup
3. Rebuild the appliance using a V9 image as per the instructions:
4. Install any patches to ensure that the patch level matches that in step 1.
5. Restore the backup from step 2. using CLI command:
- restore system
6. Install the health check patch for v9 to v9,1 upgrade.
- You should not get the error now
If you still get the error please contact IBM Guardium Technical Support and provide:
- - healthcheck<time_stamp>.log
- Output file after running CLI command:
- support must_gather system_db_info
Additional Information
Health Check Patch Release Notes
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Document Information
Modified date:
16 June 2018
UID
swg21660701