Troubleshooting
Problem
You receive the same message in the Scheduled Jobs Exceptions report at regular short intervals, typically every 5 minutes. This interval is the same as the polling interval that anomaly detection runs on.
Symptom
An example of the Scheduled Jobs Exceptions report might look like the following
v9 GUI Guardium Monitor -> Scheduled Job Exceptions
v10 GUI Investigate -> Exceptions -> Scheduled Jobs Exceptions
- Timestamp Exception Description Count of Exceptions
2013-12-05 15:51:22.0 java.lang.NumberFormatException: empty String 1
With the same exception coming every 5 minutes
Cause
There is an error that is originating from one of your active alerts.
Diagnosing The Problem
You can check the polling interval and active alerts in:
v9 GUI Administration Console -> Anomaly Detection.
v10 GUI Setup -> Tools and Views -> Anomaly Detection
Resolving The Problem
The first step to resolving the problem is to identify the exact alert that is causing the problem.
1. Deactivate one alert from the Anomaly Detection page.
2. Wait for the length of the polling interval to elapse.
3. Check to see if the errors stop with that alert deactivated.
4. If not, reactivate the alert and deactivate the next one.
5. Repeat steps 2-5 until you have tried all alerts.
Once you have found the alert causing the problem, the next steps depend on the error specifically. If you need assistance to understand or stop the error contact IBM Guardium Technical Support and provide:
- The exact error text and screen shot
- Output of the following cli commands ( if requested - specify any time to run for at least the length of one polling interval)
support must_gather app_issues
support must_gather alert_issues
Related Information
IBM MustGather: Collecting data for Guardium Appliance
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Document Information
Modified date:
16 June 2018
UID
swg21660382