IBM Support

Fail to apply Fix Pack of Load Balancer V8.5.5 with CRIMA1161E

Troubleshooting


Problem

If you installed Edge Components Load Balancer from V8.5.5 GA installation image, it fails to apply Fix pack for V8.5.5 with "CRIMA1161E: Failed to find required installation files."

Symptom

Installation Manager fails the Update Packages with the CRIMA1161E error.

For example,
-----
Failed to find required installation files.

CRIMA1161E: Failed to find required installation files.

Installation Manager did not find required installation files from the repository.  The problem is caused by a bad package, which the Installation Manager cannot resolve.

If the repository files were transferred from a different location before the installation, verify that the files were not altered during the transfer operation. Copy the repository files to a different location and install from that location. If the repository files were not transferred, note the package name and version number and contact customer support.

'zip ibmlb-lic_Win 8.5.0.0' not found in C:\inst.images\8.5.5-WS-EDGELLB-FP0000001.
-----

Cause

Updating of fix pack for V8.5.5 needs a zip file for license, ibmlb-lic_Win_8.5.0.0.zip, is accessible. But V8.5.5 GA installation image bundled another file ibmlb-lic_Win_8.5.5.0.zip.

Resolving The Problem

This error can occur when you update to V8.5.5.1 - V8.5.5.9 because of a problem accessing a license file. You can resolve it by installing the 8.5.5.1-WS-EDGELB-IFPI55786.zip Interim fix and the fix pack at the same time.

For example, if V8.5.5.0 is installed and you want to update to V8.5.5.8, follow these steps:

1. Download the 8.5.5.1-WS-EDGELB-IFPI55786.zip Interim fix.

2. Add both the location of the compressed (zip) file downloaded in step 1 and the fix pack repository to your Installation Manager repositories:
Using the graphical interface: select File->Preferences->Add Repository
Using the command line: imcl.sh... -repositories "<interim_fix_location>,<fixpack repository>"

3. Proceed to install the update.

Workaround:

You can also work around the problem instead of downloading the interim fix.

  • New installation with V8.5.0 GA image:
    1. Download the V8.5.0 GA installation image and the V8.5.5 fix pack. You do not need to download the V8.5.5 GA installation image.
    2. Add both the location of the diskTag.inf file in V8.5.0 GA image and the repository.config file in the fix pack as repositories in the Installation Manager program. 
    3. Select the "Install" button of Installation Manager, then select the latest update package level including fix pack such as "version 8.5.5.1" instead of "version 8.5.0.0".
  • Installation with Load Balancer V8.5.5 GA image
    1. Download the V8.5.5 GA installation image and the V8.5.5 fix pack.
    2. Add both the location of the diskTag.inf file in V8.5.5 GA image and the repository.config file in the fix pack as repositories in the Installation Manager program. 
    3. Select the "Update" button of Installation Manager, then select the latest update package level including fix pack such as "Version 8.5.5.1".
       
  • Users who install Load Balancer V8.5.0 GA installation image
    1. Download the fix pack. You don't need to download the V8.5.5 Refresh Pack. Note - If you remove the saved files for rollback, you need to get the V8.5.0 GA installation image. Follow the instruction in "Installation with Load Balancer V8.5.5 GA image".
    2. Add the location of the repository.config file in the fix pack as a repository of Installation Manager.
    3. Select the "Update" button of Installation Manager, then select the latest update package level including the fix pack such as "Version 8.5.5.1".

Information provided is based on the APAR PI55786 fix.

[{"Product":{"code":"SSEQTP","label":"WebSphere Application Server"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Edge Component","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"8.5.5;8.5","Edition":"Network Deployment","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
27 December 2021

UID

swg21656543