Troubleshooting
Problem
When viewing records from monitored Teradata Database in Guardium reports the DB user name field is not showing up as expected.
Symptom
Truncated or missing DB user name in reports.
Cause
The Teradata Database is not enabled to return the full (un-truncated) user name
Resolving The Problem
From the Teradata manual:
"If your site uses BAnet, Embarcadero, or Guardium monitoring software, you must use the gtwcontrol -u SendConnectRespIntegrityOnly option to enable Teradata Database to return the full (untruncated) user name, in the correct character set, to the monitoring application. Other applications are not affected.
For example: gtwcontrol -u yes -d
The -d command displays the updated GDO settings. Note: This setup returns the user name in unencrypted form. If encryption is enabled, the system returns an error message. "
Here is the full Teradata Manual
[{"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Guardium Database Activity Monitor","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"},{"code":"PF035","label":"z\/OS"}],"Version":"8.0;8.0.1;8.1;8.2;9.0","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]
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Document Information
Modified date:
16 June 2018
UID
swg21651589