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Cloned IBM InfoSphere Guardium v9 appliance unreachable from network

Troubleshooting


Problem

You cloned a v9 Guardium appliance and performed required configuration steps as explained in Technote "How to clone an IBM InfoSphere Guardium Virtual Machine" however the appliance is not reachable on the network.

Symptom

show network interface inventory command lists 2 different MACs for eth0, one MAC belongs to the original collector it was cloned from and the second MAC belongs to cloned collector. Example:

      show net int inv
      Current network card configuration:
      Device | Mac Address | Member of
      --------------------------------------------
      eth0 | 00:50:55:ad:23:e5 |
      eth0 | 00:50:55:ad:1b:f4 |

Additionally, one or more of the following symptoms may occur:

- Appliance can not be reached on the network

- Appliance can not connect to other Guardium appliances

- Registration to a Central Manager unit fails with below "Unable to connect to Remote Manager" error:


Cause

Known issue, resolved in patch SqlGuard-9.0p03.tgz.enc

Diagnosing The Problem

- Run command show network interface inventory. You are in presence of this problem if the output lists 2 different MACs for eth0, one MAC belongs to the original collector and the second MAC belongs to this cloned collector. Example:

      show net int inv
      Current network card configuration:
      Device | Mac Address | Member of
      --------------------------------------------
      eth0 | 00:50:55:ad:23:e5 |
      eth0 | 00:50:55:ad:1b:f4 |

- Run commands store network interface inventory or store network interface remap. You are in presence of this problem if error similar to the one below occurs.
      store network interface remap
      About to remap the network cards to the following configuration:

      eth0 00:50:56:ad:53:e8

      Do you want to remap the network cards to the new order.(Yes/No)
      Yes
      guard-network[8268]: WARNING About to order network interfaces
      Traceback (most recent call last):
        File "/usr/local/guardium/bin/guard-network", line 556, in <module>  remap_to_ethmacs()
        File "/usr/local/guardium/bin/guard-network", line 299, in remap_to_ethmacs ApplianceConfigHelpers.reorder_from_eth_macs()
        File "/usr/local/guardium/python/lib/python2.7/Guardium/Backend/Network.py", line 255, in reorder_from_eth_macs order.reorder(map, config_only)
        File "/usr/local/guardium/python/lib/python2.7/Guardium/Network/__init__.py", line 232, in reorder self.remap_config(map)
        File "/usr/local/guardium/python/lib/python2.7/Guardium/Network/__init__.py", line 290, in remap_config dev.HardwareAddress = map[dev.DeviceId]
      KeyError: 'eth0.bak'
      ok

Resolving The Problem

1.- Install patch SqlGuard-9.0p03.tgz.enc

2.- run these commands from the cli prompt:

      store network interface remap

      store network interface reset

      restart network

[{"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Not Applicable","Platform":[{"code":"PF016","label":"Linux"}],"Version":"9.0","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21651326