IBM Support

Sourcing rule not working based on item classification

Troubleshooting


Problem

The requirement is to use different sourcing rules based on different item classifications

Cause

Incorrect sourcing rule configuration

Diagnosing The Problem

Order gets backordered on scheduling even though there was sufficient onhand inventory.

findInventory API call returns ‘No Sourcing Rule Found’ error message.

Resolving The Problem

In order to make use of sourcing rules based on item classification, its necessary to bind each Classification Definition’ with a ‘Classification Purpose’ under ‘Catalog management > Classifications > Classification Definition’ and then add Classification values for each Associated Item attribute as described below :

1) Each Classification Purpose set up under ‘Catalog management > Classifications > Classification Definition > Classification Purpose tab’ should be bind to the required Classification Definition set up under ‘Catalog management > Classifications > Classification Definition > Classification Definition tab’.

2) Once binding is done successfully, classification values should be added under ‘Catalog management > Classifications > Classification Hierarchy’ for each ‘Classification Purpose’ (appearing in tabs) defined above.

3) Finally once classification set up is done, Primary, Secondary and Tertiary Classification types should be configured as appropriate, under ‘Item Classification’ Field within ‘Distributed Order Management > Cross Application > Order Promising > Sourcing and Scheduling > Products being shipped > Sourcing rules’

[{"Product":{"code":"SS6PEW","label":"IBM Sterling Order Management"},"Business Unit":{"code":"BU048","label":"IBM Software"},"Component":"Distributed Order Management","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"9.2","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21639408