IBM Support

User password showed as PLAIN TEXT in Engine_.log file

Troubleshooting


Problem

After upgrading SCC to 5.3.0.3 version on RedHat Linux 64bit, and trying to update the User's password in Server Properties of Connect Direct node defined in SCC, the "Update" button has failed and said: "CCTR020E Server Service Update failed." After entering valid password with GUI, and after clicking update, in such case, the Engine log file says: com.sterlingcommerce.scc.common.SCCException: CCTR020E Server Service Update failed and the user password is displayed in plain text in the engine log The failure was caused by an empty entry in the nodes xml file.

Cause

This has been identified as a product defect under APAR IC91553

Environment

The failure was caused by an empty <password/> entry in the nodes xml file.
<password/>

Resolving The Problem

Apply the latest maintenance that includes APAR IC91553

[{"Product":{"code":"SS9GLA","label":"IBM Control Center"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"5.4;5.3","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
17 December 2019

UID

swg21637787