IBM Support

Upgraded GIM client does not start

Troubleshooting


Problem

After upgrading a Guardium Installation Manager (GIM) client from version 8.2 to 9.0, the client does not start.

Symptom

When you run the command "ps -ef | grep gim" no results are returned.

Cause

The client code is upgraded successfully, but the upgrade fails to properly update the etc/inittab file.

Resolving The Problem


Edit the etc/inittab file.

Locate the line that begins "opt/IBM/GIM" for example:
/opt/IBM/GIM/9.0.0_r43212_1-1362446428/gim_client.pl

Modify the line by inserting "/modules/GIM" after GIM in the existing line, to yield:
/opt/IBM/GIM/modules/GIM/9.0.0_r43212_1-1362446428/gim_client.pl

Enter the "init q" command.

Now when you run "ps -ef | grep gim" you should see a result like this, confirming that the GIM client is running:
root 352292      1   0 19:26:59      -  0:00 /usr/opt/perl5/bin/perl
/opt/IBM/GIM/modules/GIM/9.0.0_r43212_1-1362446428/gim_client.pl

[{"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"9.0","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
16 July 2018

UID

swg21636353