IBM Support

Sterling Order Management allows Order creation with ReservationId after the expiration time

Question & Answer


Question

Why does IBM Sterling Order Management allow Order creation with ReservationId after the expiration time?

Cause

You are not able to reserve even after the expiration time.

Answer

Example Scenario:
Inventory comprises of 10 quantity and reservations are made for all the available inventory with expiration time.
Once the expiration time is elapsed, the reservation should get cancelled and product should be allow to make new reservation for the 10 quantity.
But you are not able to reserve even after the expiration time.

  1. Stock is available for Quantity 10.


  2. Reservation is made for quantity 10 with ExpirationDate as SYS date + 20 min.


  3. After 20 min, try to reserve the item.
    Reservation for the same Item is not possible(because the previous reservation still exists).


  4. Create an Order for the item.
    Order is getting created with the existing ReservationId even after 20 min.


The expirationDate in the reserveAvailableInventory is used for the reservationPurge agent.
Purge agent will delete all the records from YFS_INVENTORY_RESERVATION table, where the expiration date is less than the sysdate.

If you createOrder to not use this reservedInventory after the date has been expired, then run the reservation Purge agent.
If there is no agent running, createOrder will continue to use the Inventory.

[{"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"9.1;9.2","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21634571