Troubleshooting
Problem
Attempts to cancel an order does not refund the amount to the refund payment method in IBM Sterling Order Management
Symptom
Steps to reproduce:
The payment method is cash and the refund payment method is cheque.
For the cash payment method in refund configuration, check the flag Create Refund payment and charge request.
- Create an order with 1 line and Payment Type Cash from console.
- Execute the APIs:
requestCollection
executeCollection
requestCollection
The amount will be in Collected status and Payment status will move to "Authorized".
- Then cancel the order, and execute the API
requestCollection
executeCollection
requestCollection
As a result, the Payment status of the order moves to Await payment info and the Collected amount is not refunded to the refund payment type.
Cause
This is happening due to incorrect configuration
Resolving The Problem
Ensure that the return configuration of cheque is same as that of Cash payment type. The refund is happening to new payment type-cheque.
Therefore for cheque payment type, select the flag Create Refund payment and charge request.
[{"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"9.1;9.2","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]
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Document Information
Modified date:
16 June 2018
UID
swg21634570