IBM Support

Newly created InfoSphere Guardium virtual machine is not accessible from the network

Troubleshooting


Problem

You recently implemenetd a new InfoSphere Guardium appliance as a virtual machine and performed all the required initial network configuration. - However you can't ping the appliance using the IP address and appliance is not accesible in the network.

Symptom

ping <ip address of the appliance> fails, it is not able to find the IP for the newly created virtual machine.

Cause

Possible cause:

The MAC address assigned to the virtual machine by the virtual environment (for example, VMWare workstation) , does not match the MAC address in Guardium (show network macs).

Note: This is only one possible cause, but there may be other causes.

Diagnosing The Problem

1.- ping the IP address on a network:

      ping <appliance's ip address>

If it fails, you may be facing this issue, go to next step to confirm.

2.- show the mac address for the appliance. Login as user "cli" and run the following command to show the mac address stored in the Guardium configuration:

      show network macs

3.- From the administration utility for your virtual environment, check the MAC address for the virtual machine.


Example on how to check the MAC address of a virtual machine on VMWare Workstation 8.x:

      a) Open VMWare Workstation (usually in Start > Programs > VMWare > VMWare Workstation)

      b) Right click he virtual machine and select "Settings..." or "Properties..." to open the "Virtual Machine Settings" window

      c) Select the "Network Adapter" field under the "Hardware" tab

      d) Click on the "Advanced..." button to open the NetWork Adapter Advanced Settings

      e) The MAC address for the virtual machine will be in the "MAC Address" field as you can see in the screen shot below



4.- Compare the MAC address from steps 2 and 3. If they do not match, you are facing this problem and the solution offered in this Technote should resolve the problem.

Resolving The Problem


1.- Login to the Guardium appliance as user "cli"

2.- Run command:

      store network interface inventory

The appliance will warn about resetting the NICs. Respond with "y"

3.- restart the system as user cli (command "restart system") once the previous command is done. The problem should be resolved when the system is back from the restart

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Document Information

Modified date:
16 June 2018

UID

swg21633946