IBM Support

java.lang.IllegalStateException error in IBM InfoSphere Guardium Graphic Interface (GUI)

Troubleshooting


Problem

You are trying to use the IBM InfoSphere Guardium Graphic Interface (GUI) and receive error: "java.lang.IllegalStateException"

Symptom

Error java.lang.IllegalStateException in the GUI, similar to this:


Cause

The error java.lang.IllegalStateException is raised when a method is invoked when the Java VM is in a state that is inconsistent with the method.There may be corrupted Java servlets. This can also be caused by deadlocks.

Resolving The Problem

Please wait for a few minutes and retry, in case this is a transient problem. If the error persists, the web interface (GUI) must be restarted. Login as user 'cli' and restart the GUI with command:

      restart GUI
If the above does not help, execute the following command as user 'cli' to cleanup the Java servlets:

      support clean servlets

If the problem is not resolved, please collect the following tomcat logs using the fileserver command and contact IBM InfoSphere Guardium Technical Support:

    tomcat_log/localhost.<date_stamp>.log
    tomcat_log/catalina.<date_stamp>.log.

For example:

    tomcat_log/localhost.2012-12-03.log
    tomcat_log/catalina.2012-12-03.log

The steps to use the fileserver command can be found in the following technote:

http://www.ibm.com/support/docview.wss?uid=swg21499434

[{"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF016","label":"Linux"}],"Version":"9.0;8.2;8.0.1;8.0","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21619563