Troubleshooting
Problem
Getting alerts when a BP ran successfully on the Sterling B2B Integrator (SI) node. The BP runs successfully, but is run with full persistence and there are a few steps that have status "JMS Queued" and "BP queued" which apparently equate to WF_STATUS 11 and 12. These statuses are apparently being passed to Sterling Control Center (SCC) as "inError true", which in turn causes a return code 8, thus causing alerts to be issued (a rule is set up to alert if return code is not 0).
Symptom
SCC rule is set up to alert if return code is not 0
Cause
This has been identified as a product defect under APAR IC87312
Environment
Sterling Control Center monitoring SI
Diagnosing The Problem
Review the Database Events report on SCC and Business Process History on SI
Resolving The Problem
Added status codes 11 and 12 to a table in Sterling Control Center. These entries indicate to treat these conditions as successful.
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Document Information
Modified date:
17 December 2019
UID
swg21616485