IBM Support

What does the Guardium alert "Failed Purge Object Job for 'Kerberos Authentication Info.' removed records older then" mean? How do I get rid of the alert?

Question & Answer


Question

What does the alert "Failed Purge Object Job for 'Kerberos Authentication Info.' removed records older then" mean? How do I get rid of the alert?

Cause

The alert indicates purging failed of an internal Guardium table that stores Kerberos Authentication information called GDM_SECURE_PARAMS. The table is often edited by guardium and this can cause locking problems so that a purge of it fails.

Answer

Please monitor the alert. If you get the alert at every purge and the table is very large then this is an issue. The table is called GDM_SECURE_PARAMS. You can monitor your largest tables with the cli command "support show db-top-tables all".

If you get this alert occasionally it's not an issue. If it fails to purge at day X and then purges the next day it's not an issue.

If you are hit by this issue then go to the latest v8.2 GPU fix pack, the problem is resolved in v8.2p100. Alternatively upgrade to version 9.

You can find the latest GPU in IBM Fix Central:

http://www-933.ibm.com/support/fixcentral/

choose:


    Product: InfoSphere Guardium
    Installed Version: 8.2.0
    Platform All

Look for the most recent patch with GPU in the title. e.g. SqlGuard-8.2p230_GPU_March_2014

[{"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Not Applicable","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"},{"code":"PF035","label":"z\/OS"}],"Version":"8.2;8.0.1;8.0","Edition":"All Editions","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21615560