Troubleshooting
Problem
Installation fails with the following error message: Caused by: java.sql.SQLNonTransientConnectionException: java.net.ConnectException : Error connecting to server 127.0.0.1 on port 51836 with message Connection refused. at: org.apache.derby.client.am.SQLExceptionFactory40.getSQLException(Unknown Source)
Symptom
The installation log (IA log) shows below errors:
Caused by: java.sql.SQLNonTransientConnectionException: java.net.ConnectException : Error connecting to server 127.0.0.1 on port 51836 with message Connection refused.
at: org.apache.derby.client.am.SQLExceptionFactory40.getSQLException(Unknown Source)
at: org.apache.derby.client.am.SqlException.getSQLException(Unknown Source)
at: org.apache.derby.jdbc.ClientDataSource.getConnection(Unknown Source)
at: org.apache.derby.jdbc.ClientDataSource.getConnection(Unknown Source)
at: com.ibm.ac.si.db.DbmsControl.getConnection(DbmsControl.java:910)
at: com.ibm.ac.si.db.DbmsControl.getConnection(DbmsControl.java:1004)
GC - 20101027_AA (from com.ibm.ac.coi.ext.ia.DaemonRestart.run)
2012-08-16 06:35:32.356+00:00 : FINE : Could not start the ACSI Daemon server... (from com.ibm.ac.coi.ext.ia.DaemonRestart.run)
2012-08-16 06:35:32.358+00:00 : FINER : THROW (from com.ibm.ac.coi.ext.ia.DaemonRestart.run) Caused by: com.ibm.ac.si.nls.SIException:
at: com.ibm.ac.si.runtime.impl.SIRuntimeImpl.<init>(SIRuntimeImpl.java:193)
at: com.ibm.ac.si.runtime.SIRuntimeFactory.createRuntime(SIRuntimeFactory.java:221)
at: com.ibm.ac.si.runtime.SIRuntimeFactory.createRuntime(SIRuntimeFactory.java:124)
at: com.ibm.ac.coi.ext.ia.DaemonRestart.run(DaemonRestart.java:80)
at: com.ibm.ac.coi.ext.ia.plugin.DEBootstrapAction.Result(DEBootstrapAction.java:272)
at: com.ibm.ac.coi.ext.ia.DEBootstrapWorkerThread$ResultDispatch.run(DEBootstrapWorkerThread.java:218)
at: java.util.Timer$TimerImpl.run(Timer.java:295)
Caused by: com.ibm.ac.si.db.DatabaseException:
at: com.ibm.ac.si.db.DbmsControl.getConnection(DbmsControl.java:924)
at: com.ibm.ac.si.db.DbmsControl.getConnection(DbmsControl.java:1004)
at: com.ibm.ac.si.runtime.impl.SIRuntimeImpl.<init>(SIRuntimeImpl.java:189)
at: com.ibm.ac.si.runtime.SIRuntimeFactory.createRuntime(SIRuntimeFactory.ja
va:221)
at: com.ibm.ac.si.runtime.SIRuntimeFactory.createRuntime(SIRuntimeFactory.ja
va:124)
at: com.ibm.ac.coi.ext.ia.DaemonRestart.run(DaemonRestart.java:80)
at: com.ibm.ac.coi.ext.ia.plugin.DEBootstrapAction.Result(DEBootstrapAction.
java:272)
at: com.ibm.ac.coi.ext.ia.DEBootstrapWorkerThread$ResultDispatch.run(DEBoots
trapWorkerThread.java:218)
at: java.util.Timer$TimerImpl.run(Timer.java:295)
Cause
The derby database was not started.
Diagnosing The Problem
1. Try running ping command and check if these commands do not time out.
$ ping localhost
$ ping HostName (replace HostName with actual hostname)
2. Run below command to check if the port mentioned in above error message (eg; 51836) is not being used by another application.
- $ netstat -an
3. Run below commands and check if these commands fails to run. The location of these commands vary depending if the installation was done as root user or as a non-root user.
$ de_version
$ listIU.sh
$ de_lsrootiu.sh
If you do not find any issue with these diagnostics steps then proceed to next section.
Resolving The Problem
It is possible that the DE encounters the timeout when trying to start the derby database. If this is is the case, Increase derby server startup time to 200 sec. By default it is 90 sec.
Set below environment variable in command prompt/ssh terminal and then restart the installer in same command prompt/ssh terminal
- On Windows :
- On Unix :
If above steps didn't help to resolve the issue then start the derby database manually as below and try the installation again:
Windows:
% cd C:\Program Files\IBM\Common\acsi\repos
Unix:
For root installation:
- $ cd /usr/ibm/common/acsi/bin
$ cd <Install User's HOME>/.acsi_<install_username>/repos
$ java -cp ../lib/derby.jar:../lib/derbyclient.jar:../lib/derbynet.jar:../lib/derbytools.jar org.apache.derby.drda.NetworkServerControl start -noSecurityManager
If the installation fails again the please open a PMR and provide logs as described in below technote:
https://www-304.ibm.com/support/docview.wss?uid=swg21468983
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Document Information
Modified date:
17 June 2018
UID
swg21613012