Troubleshooting
Problem
Attempts to set the IBM Rational ClearCase CLEARCASE_PRIMARY_GROUP variable results in a Blue Screen Stop Error (BSOD) on Microsoft Windows.
Symptom
Steps to reproduce:
- Log on as a user on Windows
- Set CLEARCASE_PRIMARY_GROUP as a user environment variable.
For example, CLEARCASE_PRIMARY_GROUP=clearcase_users.
- Log off
- Log on as the user.
Expected result: Log in with no errors
Actual result: You experience a Blue Screen Stop Error (BSOD).
Note: This problem can also occur when you are logged in an run ntlogon_util.exe -r or nplogon.exe to update CLEARCASE_GROUPS or CLEARCASE_PRIMARY_GROUP variables.
Cause
This issue was identified as a product defect and logged under APAR PM40970.
A STOP error was being triggered by code in MVFS which protects against recursive locking calls. This logic exists to prevent a hang from occurring, and indicated a flaw in the locking logic for certain combinations of actions.
Resolving The Problem
The defect is fixed starting in Rational ClearCase versions 7.1.1.7 and version 7.1.2.4.
Related Information
[{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Environment Variables","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.1.1;7.1.1.1;7.1.1.2;7.1.1.3;7.1.1.4;7.1.1.5;7.1.1.6;7.1.2;7.1.2.1;7.1.2.2;7.1.2.3","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]
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Document Information
Modified date:
16 June 2018
UID
swg21612395