IBM Support

Script error - "either the script was running longer than the timeout period of 5 seconds or the script length was more than 50,000 lines"

Troubleshooting


Problem

Some scripts might display an error in the client.log.
  [http-nio-443-exec-2] INFO c.c.web.rest.Co3ExceptionMapperBase - Mapping exception to REST  com.co3.domain.exceptions.Co3IllegalArgumentException: either the script was running longer than the timeout period of 5 seconds or the script length was more than 50,000 lines.     at com.co3.web.services.ScriptExecutionService.execute(ScriptExecutionService.java:90)     at com.co3.web.rest.ScriptREST.executeScript(ScriptREST.java:104)    
When testing the script the error is also seen.
error

Symptom

Clients might find that scripts are not running and this often occurs with an email script and emails are not being parsed and ingested to IBM Resilient.

Cause

Resilient allows for a script to run through 50,000 lines or to run for 5 seconds. The error is reported when the script exceeds one of those two requirements. These two values stop a script from looping infinitely, which could have an effect on system stability.

Resolving The Problem

Defensively written code should keep looping in mind. Email scripts often use complex regex, which can cause this problem. In cases such as these, review your code and if needed get in touch with the IBM Resilient Community for advice.

Document Location

Worldwide

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Document Information

Modified date:
19 April 2021

UID

ibm14790679