Troubleshooting
Problem
User launches Controller client (ccr.exe). User is prompted with database selection, and chooses relevant database.
Afterwards, however, instead of being prompted to logon (or to choose the period) the users client session disappears.
Symptom
Controller client crashes/ends/disappears during logon process. There is no message recorded inside the Event Viewer.
Cause
There are many different potential causes for similar behaviour/symptoms.
This Technote specifically relates to the scenario where the cause is that "Cognos Configuration" is configured incorrectly.
- TIP: For more examples, see separate IBM Technote #374171.
This Technote specifically relates to the scenario where the cause is that "Cognos Configuration" is configured incorrectly.
- Specifically, the customer had configured "Allow anonymous access" to be set to "True":
This caused Controller to not be able to search the Active Directory namespace to validate the user to logon.
Environment
Controller configured to use (Cognos) CAM Authentication (previously known as 'Cognos 8' authentication):
Resolving The Problem
Inside "Cognos Configuration", change "Allow anonymous access" to be set to "False".
- TIP: For more information see separate IBM Technote #1380097.
Steps:
- Logon to Report Server (BI server) as an administrator
- From the Start Menu, launch "Cognos Configuration"
- Expand section "Local Configuration - Security - Authentication - Cognos"
- Ensure that the setting "Allow anonymous access" is set to "False"
- After making changes, restart the Cognos reporting service.
Related Information
[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
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Document Information
Modified date:
10 March 2020
UID
swg21595071