IBM Support

Increasing platform.xml files may cause high disk-space usage

Troubleshooting


Problem

On WebSphere Application Server V7, XML files may increase everytime you run startup and stop comands for dmgr/nodeagent/appserver processes. It may cause a high disk-space usage requiring users to monitor and maintain.

Cause

Everytime you run startServer/stopServer/serverStatus/wsadmin/manageprofiles commands, platform.xml file is copied to history directory and it causes a high disk-space usage over a long period of time. These commands would need to be run hundreds of thousands of times for size to become a problem as each run creates about a 2KB file, it would take nearly 500 runs to generate 1MB on the filesystem.

The path for platform.xml file is "<Profile_ROOT>/configuration/org.eclipse.update/platform.xml" and history directory is "<Profile_ROOT>/configuration/org.eclipse.update/history".

The size of a platform.xml is about 1KB-2KB but this platform.xml file is copied everytime customers run startServer/stopServer/serverStatus/manageprofiles commands.

Environment

All users of WebSphere Application Server version 7.0 for all edition, all platforms(AIX , HP-UX , i5/OS , Linux , Solaris , Windows)

Diagnosing The Problem

Check whether xml files are increasing in your environment in the 'history' folder as described.

Resolving The Problem

Open <Profile_ROOT>/configuration/org.eclipse.update/platform.xml with any editors. Change "transient" parameter from "false" to "true".

  <config date="1276249438156" transient="true" version="3.0">

You do not need to restart servers.
After you change transient="true", no backup files of platform.xml create any more under <Profile_ROOT>/configuration/org.eclipse.update/history directory.

This setting change is only used for eclipse plugin configuration, so it does not affect to any runtime of WebSphere Application Server.

About the generated platform.xml under <Profile_ROOT>/configuration/org.eclipse.update/history is safely deleted.


Note: This problem does not occur for WebSphere Application Server V8 users.

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Document Information

Modified date:
15 June 2018

UID

swg21590262