IBM Support

Missing tabs in the GUI for a Guardium user

Troubleshooting


Problem

The Guardium Graphic Interface (GUI) is missing tabs for a user in IBM InfoSphere Guardium.

Symptom

You login to the Guardium Graphic Interface (GUI) with a user and there are missing tabs that you expect to see.

Cause

Some possible causes are:
- the user does not have assigned the role that includes the missing tabs
- the user layout needs to be restarted
- another cause

Resolving The Problem

If there is another useru2 who can see the missing tabs:


    1) login to the GUI as accessmgr user

    2) go to User Browser and find the user who can see the tabs

    3) click in Edit Roles and take note of all the roles for this user

    4) go to User Browser and find the user that is having problems. Click in Edit Roles for this user.

    5) Make sure this user has ALL the roles the other user has. IF a role is missing, add it to this user and save it.

    6) If changes were made to the user roles (ie. added roles), reset the layout for this user. To do this, in User Browser, locate the user you added roles to and click on Change Layout, then on Reset to reset the layout

    7) if problem continues, login as cli to the appliance and run: restart GUI

    8) if problem continues then create a Customer Role Layout as follows:


      1. First, create a New Customer Role.

        Login into the appliance as a user with the accessmgr role. Click on Security Role Browser. Click Add Role. Add a new role with any name you want, ie. custom_role

      2. Open the CLI and execute the following command:

        generate-role-layout [user] [role]

          where [user] is the username that has the tabs and [role] is the new role.

      3. Log into the GUI as a user with the accessmgr role and create a new user with the ‘user’ role, set his role as the new custom role. The user will have the same layout as the other user. Note the customer role must be assigned prior to the new user’s first login. If the user logs in before the customer role is applied, the user will not be assigned the menu layout associated with the customer role.

      4. Now log on as the new user The user will have the same layout as the other user who sees the tabs.


        For version 9.x,

        If any changes are made by useru2 after this step 8.4 (E.g. adding another tab), step 8.2 will need to be carried out again for the changes to be reflected on the GUI for users assigned to the role.

        On the user account if the user does not have the correct layout they should perform the following to update their layout to the intended role layout. :-
          Edit Account > Layout > Reset.

[{"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Guardium Database Activity Monitor","Platform":[{"code":"PF016","label":"Linux"}],"Version":"9.0;8.2","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21569081