Troubleshooting
Problem
Cognos : Database connection fails intermittently(Oracle version 10.2.0.3)
Symptom
We have seen instances were the Content Manager data source connection fails intermittently.
This issue is seen if the Oracle version is 10.2.0.3
Error MessageConnection failed
Resolving The Problem
Add the 'Open
session commands' to set the cursor sharing to exact.
Root Cause:
Issue may be related to Oracle bug number #5863277.
Steps:
This
setting can be defined at the database level or session level.
a)
Database level setting has to be done on the Oracle Enterprise Manager Console
or Database Control.
b) The session level setting can be done via the
Cognos data source definition screen.
Log on as the administrator in
Cognos Connection, Click on 'Tools - Directory'.
Open the properties
sheet of the required data source.
Click on the 'Connection' tab.
Click on the 'Set' option of the 'Open session commands' line.
Add the
commands in the dialog box. (See the "Administration and Security Guide" under
the section 'Use Database Command', for more details on defining the XML
statements.) For example:
<commandBlock>
<commands>
<sqlCommand>
<sql>ALTER SESSION SET CURSOR_SHARING= EXACT</sql>
</sqlCommand>
</commands>
</commandBlock>
Related
documents:
1. Cognos 8 Administration and Security Guide - Chapter 5 -
Manage Data Source Connections 2. Oracle forums on this error:
http ://forums.oracle.com/forums/thread.jspa?threadID=465415&tstart=0
3. Information on cursor sharing at:
Historical Number
NFX4337
Product Synonym
[<p><b>]Severity[</b><p>];Normal
Was this topic helpful?
Document Information
Modified date:
16 June 2018
UID
swg21551597