Troubleshooting
Problem
Cannot connect to Connect:Enterprise node
Symptom
Cannot connect to Connect:Enterprise node
Control Center error:
CCTR035E
Error: Failed to connect to server. Check for invalid
userid/password, improper authority for userid, unsupported level of server or
no license slot available to monitor the server.
Enterprise Admin GUI error:
504 failed to connect.
The Connect:Enterprise SVD trace shows this error:
rapi_open_role: failed acqopenifile - rc = 12
Cause
Connect:Enterprise installation was not completed properly, roles and admin databases were not created. Connect Control Center and Enterprise Administration Tool requires that the userID that accesses the Connect:Enterprise server has an Administrator role
Resolving The Problem
Issue the following commands from the $CMUHOME/database directory:
../<OS>/bin/create.roles.db create
../<OS>/bin/create.admin.role create <ceuser>
Historical Number
PRI6775
Product Synonym
[<p><b>]Fact[</b><p>];[<p>]Connect Control Center Windows (Engine);All Releases[</p>] ;[<p>]Connect:Enterprise UNIX Administration Tool;All Releases[</p>]
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Document Information
Modified date:
17 December 2019
UID
swg21532915