IBM Support

Attempts to start DOORS client result in the error "The secure connection failed..The secure socket was forcibly closed"

Troubleshooting


Problem

Attempts to log into a database after you upgrade IBM Rational DOORS result in the error "The secure connection failed. .The secure socket was forcibly closed. DOORS will now exit."

Symptom

When you attempt to login to a DOORS database an error message displays.
The full error message is as follows:

"The secure connection failed. .The secure socket was forcibly closed. DOORS will now exit."

image

When you Click OK DOORS does not start.

Cause

The DOORS database login policy is set to prevent your version of software from connecting to the database.

Resolving The Problem

There are two methods to resolve this issue.

  • You can use the previous version of the DOORS client to login to the database and update the maximum client version value. You must have the power to manage the database.

    Procedure:
      1. Log into DOORS

      2. Right Click the database icon

        image


      3. Select Properties...

      4. Select the Login Policy Tab

        image


      5. Enter the Maximum client version to include the version of DOORS client you intend to use for connections to the database.

      6. Click Apply

      7. Click OK to close the properties window.

      8. Close DOORS
      9. Restart the DOORS database server

      1.
  • Send the database configuration file server_settings.dtc to support for manual update.

    Procedure:
    1. Identify the database file location from the DOORS database server registry key.
      For example:
      [HKEY_LOCAL_MACHINE\SOFTWARE\Telelogic\DOORS_Server\9.4\Config]
      ServerData"="C:\\Program Files (x86)\\IBM\\Rational\\DOORS\\9.4\\data\\

    2. Navigate to the serverdata directory

    3. Copy the file server_settings.dtc to send to support

    4. Provide the file to support along with instructions identifying the maximum client version

    5. When the file is returned to you by support you must stop the DOORS database server then replace the existing server configuration file

    6. Restart DOORS database server.

[{"Product":{"code":"SSKR2T","label":"IBM Engineering Requirements Management DOORS"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"General Information","Platform":[{"code":"PF033","label":"Windows"}],"Version":"9.2;9.2.0.1;9.2.0.2;9.2.0.3;9.2.0.4;9.2.0.5;9.3;9.3.0.1;9.3.0.2;9.3.0.3;9.3.0.4;9.3.0.5;9.3.0.6;9.3.0.7;9.4;9.4.0.1;9.5;9.5.0.1;9.5.1;9.5.1.1;9.5.1.2","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
01 May 2020

UID

swg21460217