Troubleshooting
Problem
Attempts to update the index results in the error "Failed to optimize search index" in the event.log for IBM Rational Change 5.1 and later.
Symptom
You may observe that a recently added Change Request(CR) is not found in a search.
When you look in the event.log
you may find one of the following error messages:
2010/03/24 12:50:47 ERROR: Failed to optimize search index.
Stack trace: java.io.IOException: background merge hit exception: _28v:
c1 _29o:c3 _29p:c1 _2aw:c2 _2ax:c1 _2c4:c2 _2c5:c1 _2dc:c1 _2dd:c9 _2dn:
c1 into _2ei [optimize]
or
2012/05/11 08:45:07 ERROR: Failed to optimize search index.
Stack trace: java.lang.NullPointerException
at org.apache.lucene.store.BufferedIndexOutput.writeBytes
(BufferedIndexOutput.java:49)
at org.apache.lucene.store.IndexOutput.writeBytes
(IndexOutput.java:40)
Cause
This is caused by a defect in the Lucene optimizer reported in APAR PM12008.
Diagnosing The Problem
Review the event.log
and see if there is either of the error messages reported above.
Resolving The Problem
This problem is resolved with IBM Rational Change ifix 5.2.0.2.02.
Install the latest patch and disable the Search Optimizer with the following entry to the pt.cfg
file:
[CCM_SYSTEM][SEARCH_OPTIMIZE_TIMER_MINS]0[/SEARCH_OPTIMIZE_TIMER_MINS][/CCM_SYSTEM]
This change will take effect when you restart the Rational Change server.
Even if you have already installed the patch you will still get the error until you make the change to the
pt.cfg
file and restart the Rational Change server.
Related Information
Was this topic helpful?
Document Information
Modified date:
13 November 2019
UID
swg21449247