Troubleshooting
Problem
Attempts to test the connection to agent computers yields security message "the Agent Controller is not available on host
Symptom
The full error message reads as follows.
Connection failed on host <host name>.
Reason:
IWAT0284E The Agent Controller is not available on host <host name>
Make sure that:
* for localhost, the Internal Agent Controller is supported on your local
platform.
* the Agent Controller is installed.
* the Agent Controller is configured to communicate with your machine.
* you have the correct host name and port number for the Agent
Controller.
See the workspace Error Log or Agent Controller serviceconfig.log for any
additional information.
Under details you see.
org.eclipse.hyades.internal.execution.local.control.
AgentControllerUnavailableException
STEPS TO REPRODUCE
- Click Window > Preferences.
- Expand Agent Contoller. Then, click Hosts.
- Highlight the agent computer. Then, click Test Connection.
Case A: The agent computer is the local host
You test the connection to the local host.
A Test runs error free.
Case B: The agent computer is a remote host
The remote hosts are running the Agent Controller service but the error is still occurring.
Note
The test connection function does not apply to versions 8.3 and newer, Use the Agent Status button from the toolbar instead.
Cause
Case A
- The definition of the local host as Location is lacking.
- The local host does not have the Agent Controller software.
- The IBM Rational Agent Controller service is not running.
Case B
- The 10002 port is closed.
Diagnosing The Problem
Case B
Run the following command from the command-line to verify that the port is open.
telnet <host> <port>
Resolving The Problem
Case A
- Define the local host as Location.
- Install the Agent Controller through the IBM Installation Manager.
- Start the IBM Rational Agent Controller.
Case B
- Ask your network administrator to open port 10002.
Related Information
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Document Information
Modified date:
16 June 2018
UID
swg21424848