IBM Support

Browsing a Rational DOORS URL results in "Unable to open DOORS URL" error

Troubleshooting


Problem

Attempts to browse IBM Rational DOORS URL results in the error "Unable to open DOORS URL. Failed to start DOORS client. (You must have access to an authenticated DOORS session in order to open a DOORS URL)".

Cause

Error occurs if time-out period for Flex to issue a license and the time taken to login to Rational DOORS is not long enough.

Resolving The Problem

You can increase the time that Rational DOORS client waits for flex to issue a license and also the time that Rational DOORS client waits before a log in takes place. The parameters on the protocol handler controls this (measured in half seconds). You can increase the time outs by a factor of 2.

Navigate to the following registry setting on the client machine:

HKEY_CLASSES_ROOT\doors\shell\open\command

and check the value of the following Default key

If it is:

C:\IBM\Rational\DOORS\9.2\bin\protocolhandler.exe -r 240 -s 60 -url %1

Change it to:

C:\IBM\Rational\DOORS\9.2\bin\protocolhandler.exe -r 480 -s 120 -url %1

[{"Product":{"code":"SSKR2T","label":"IBM Engineering Requirements Management DOORS"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"General Information","Platform":[{"code":"PF033","label":"Windows"}],"Version":"9.2.0.2;9.2.0.1;9.2","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
01 May 2020

UID

swg21420656