IBM Support

Opening a module results in the error Lock request timed out

Troubleshooting


Problem

Unable to open a module in IBM Engineering Requirements Management DOORS® that results in an error message "Lock request timed out"

Symptom

Unable to open a module

Cause

This issue is due to a lock still in place in the database on the module

Resolving The Problem

First step, you can try to go in DOORS in "Tools" -> "Manage locks" and remove the locks that are on the module. If this method does not work, follow the next instructions.
  1. Contact your database administrator to remove the lock by using DBSAdmin tool. The tool is located in the bin directory in the DOORS folder.
  2. Once the DBSAdmin tool is open, the administrator needs to enter the connection details such as the port@hostname of the server in the field "Database Server" and the password,
  3. Next, click "Refresh List".
  4. A connection is established between the tool and the database.
  5. On the "Users and locked files", the administrator can see the users or locks that are still in use.
  6. Click "Disconnect User" for an inactive user (who possibly locked the module, and disconnected incompletely).
  7. Identify the one that is on your module and click "Unlock File".
  8. If the above steps do not solve the error, you can restart DOORS Service or the DOORS server.

You might have several locks on the same file, you have to remove them all in order to open the module correctly.

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Document Information

Modified date:
31 December 2023

UID

swg21396976