Troubleshooting
Problem
Symptom
Cause
- If the TEMPDB database has a different collation (from the Controller database) then errors can occur
- It is therefore vital that the Controller database has *exactly* the same collation as the TEMPDB database.
Environment
Diagnosing The Problem
Logon to the SQL server, and perform the following steps:
1. Launch "SQL Server Management Studio"
2. Expand "Databases - System Databases" and locate the database "tempdb"
3. Right-click on 'tempdb' and choose 'Properties':
4. Make a note of the collation (for example "SQL_Latin1_General_CP1_CI_AS"):
5. Right-click on your Controller application repository database (for example "ControllerLive") and choose "properties"
6. Make a note of the collation (for example "Latin1_General_CI_AS").
Resolving The Problem
- This will be your 'target' database
- Specifically, use 'Database Conversion' to convert it to the same Controller version as the 'source' database currently is
Related Information
1345692 - Unable to connect: Exception has been thrown
1388368 - Error 'Cannot resolve the collation conflict
1371934 - How to migrate a database from SQL to Oracle
873220 - Export and import Cognos Controller data - how to install/use the Cont…
THIRD PARTY (non-IBM) - Change Database Collation
THIRD PARTY (non-IBM) - scripts for converting database
Was this topic helpful?
Document Information
Modified date:
16 January 2020
UID
swg21394936