Troubleshooting
Problem
A database backup initiated by the BACKUP DB command on a Tivoli Storage Manager V6 AIX server fails with sqlcode: -2033 and sqlerrmc: 106.
Cause
The Tivoli Storage Manager server instance error log file is owned by root instead of the server instance user ID.
Resolving The Problem
Perform the following steps to correct the problem. The example uses a Tivoli Storage Manager server instance user ID named "db2inst1" and a server instance directory named /home/db2inst1/tsminst1/
.
- Log on with the Tivoli Storage Manager server instance user ID and verify the name of the error log. For example :
$ grep -i "ERRORLOGNAME" $DSMI_DIR/dsm.sys
ERRORLOGNAME /home/db2inst1/tsminst1/tsmdbmgr.log
- Verify the current ownership of the error log file. For example :
$ ls -la /home/db2inst1/tsminst1/tsmdbmgr.log
-rw-r--r-- 1 root system 834 May 05 09:43 /home/db2inst1/tsminst1/tsmdbmgr.log
- If the error log is not owned by the Tivoli Storage Manager instance user ID, remove it. If the error log is owned by root and you are currently logged on with the server instance userid, you need root authority to remove the file. For example :
$ su (enter root password)
# rm /home/db2inst1/tsminst1/tsmdbmgr.log
# exit
- Run the BACKUP DB command and verify successful completion. The error log file is recreated and should now be owned by the Tivoli Storage Manager server instance user ID. For example :
$ ls -la /home/db2inst1/tsminst1/tsmdbmgr.log
-rw-r--r-- 1 db2inst1 db2iadm1 834 May 05 09:50 /home/db2inst1/tsminst1/tsmdbmgr.log
[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Server","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Supported Versions","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]
Product Synonym
tsm
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Document Information
Modified date:
17 June 2018
UID
swg21385178