Troubleshooting
Problem
User launches the Controller client. User receives error message. Administrator looks at Event Log on application server, and sees error recorded inside 'Application log'.
Symptom
Screen:
Depending on the version of Controller, the error may vary slightly, but it should look similar to:
An error occurred while trying to access server
Error Details:
System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> System.Runtime.InteropServices.COMException (0x8000401A): Retrieving the COM class factory for component with CLSID {114133CF-5DC0-4DB1-8796-4642553B2499} failed due to the following error: 8000401a.
at Cognos.Controller.Proxy.CCRWS.ConnectionBusiness_SetSelectDb(String sGuid, String sUser, Boolean bSelectDb)
Event Viewer (Application Log):
Event Type: Warning
Event Source: Cognos Controller
Event Category: None
Event ID: 0
Date: 2008-03-05
Time: 16:19:14
User: N/A
Computer: SERVERNAME
Description:
Error occured at 05/03/2008 15:19:14 in Cognos Controller, Error No=5, Source=FrangoDirect.ConnectionDirect.SetSelectDb#ControllerProxyClient, Description=System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> System.Runtime.InteropServices.COMException (0x8000401A): Retrieving the COM class factory for component with CLSID {114133CF-5DC0-4DB1-8796-4642553B2499} failed due to the following error: 8000401a.
at Cognos.Controller.Proxy.CCRWS.ConnectionBusiness_SetSelectDb(String sGuid, String sUser, Boolean bSelectDb)
Cause
The screen message 'An error occurred while trying to access server' is a generic error. There are many different potential causes for this message.
- TIP: For more examples, see separate IBM Technote #1366724.
This IBM Technote specifically relates to the scenario where the screen/Event Log contains the following text:
(0x8000401A): Retrieving the COM class factory for component with CLSID {114133CF-5DC0-4DB1-8796-4642553B2499} failed due to the following error: 8000401a.
In this case, the error is caused by a problem with the configuration of the COM+ subsystem.
- Specifically there is a problem with the identity of the Windows user who is running the COM+ application:
Examples:
There are several potential causes for this specific error in the Event Log.
- See more examples inside separate IBM Technote #1371331.
The most common causes are:
Scenario #1 (common) - Only applicable to Controller 10.1.1 and earlier:
I.T. administrator has mistakenly configured the COM+ Server to use the identity 'System Account':
This causes the Component Services (COM+) package 'COGNOSCONTROLLER' to have insufficient permissions to run the Controller application server.
- NOTE: For Controller 10.1.1 and earlier, the Controller COM+ application must run under a Domain User account to allow advanced functionality (such as 'Optimise2') to work as intended.
Controller is being run inside an environment which has unusually restrictive COM+ permissions.
Resolving The Problem
Scenario #1 - (common)
Modify COM+ user value in Controller Configuration, so that it runs under a Windows domain user ID that is a member of the application server's local 'Administrators' group.
- Steps:
- If you do not do this, there is a possibility that (for example every few days) your user will be removed from the 'Administrators' local group, and therefore Controller will stop working.
- For full details (including printscreens) of how to achieve the above, search for best practice server installation documentation inside the IBM Cognos Proven Practice website and/or separate IBM Technote #1608353.
1. Create a Windows domain (Active Directory) user (for example 'DOMAIN\controller_system') which will act as the 'service' account for Controller
2. Ensure that this domain user's password is not configured to expire (for example every month)
3. IMPORTANT: Ask the Active Directory administrator to ensure that the customer does not have a policy (for example an AD 'Group Policy') which periodically automatically removes non-recognised accounts (for example 'DOMAIN\controller_system') from the local 'Administrators' group on servers
4. Logon to the Controller application server as an administrator
5. Right-click on 'My Computer', and choose 'Manage'
6. Expand 'Local Users and Groups - Groups'
7. Double-click to open up 'Administrators'
8. Add the domain user (for example 'DOMAIN\controller_system') to this 'Administrators' local group
9. Launch 'Controller Configuration' from the Start Menu
20. In the tree control in the left pane, expand Cognos Controller Configuration > Web Services Server > COM+ Server
21. In the right pane, select the Specify Account option
22. Enter the administrative Windows user in the User edit field (for example 'domain\controller_system')
23. Enter and confirm the password
24. In the Controller COM+ roles and users, click in the area, and then click the New ('white page of paper') button from the main tool bar
25. In the COM+ Role, enter a suitable name, such as 'ControllerUsers'
26. In the COM+ User, enter 'everyone'
27. Repeat the three previous steps, but enter 'NT AUTHORITY\SYSTEM' as the user
28. Click on 'SAVE' icon (top left corner)
TIP:
Scenario #2 - (rare)
This scenario rarely occurs.
- If you have a restrictive environment (for example, some configurations of Windows XP) then you may need to ensure that 'Enforce Access checks' is unticked on the Controller COM+ package.
- Steps:
- (This is required to be able to modify the COM+ package).
1. Start Controller Configuration on the Controller application server.
2. Select the section 'COM+ Server' in the tree structure.
3. Untick the option 'Enforce access checks for the Controller COM+ application':
4. Type in the password of the configured identity in 'Password:' and 'Confirm Password:'
5. Press the 'Save' button (to save the new configuration).
Related Information
Historical Number
1041342
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Document Information
Modified date:
15 June 2018
UID
swg21367316