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** Troubleshooting ** Consolidations fail with error - 'The ODBC connection is missing or invalid'

Troubleshooting


Problem

User runs a consolidation. Afterwards, user opens 'Manage Batch Queue'. Batch ID has message 'Finished with error' Double-clicking on this Batch ID shows an error message.

Symptom

Details Section <id number>
Text
<....>
The ODBC connection is missing or invalid.

Cause

There are many potential causes for the error message "The ODBC connection is missing or invalid":

  • Scenario #1 - Database provider not installed correctly (on the Controller application server).
  • Scenario #2 - Non-English Oracle client version installed on Controller application server.
    • For more information, see separate IBM Technote #1370908.
  • Scenario #3 - Defect in early Controller 8.5.x versions, triggered when using the Database Provider "SQLNCLI10.1"
    • For more information, see separate IBM Technote #1430066.
  • Scenario #4 - Corrupt/invalid installation of Oracle 10G rel2 client on Controller Application server.
    • For more information, see separate IBM Technote #1347585.
  • Scenario #5 - Defect in Controller 10.1.1 and earlier, triggered when using the Database Provider 'SQLNCLI11.1'
    • For more information, see separate IBM Technote #1962603.
  • Scenario #6 - Both of the following are true:

1. The customer has manually customised their database connection (UDL file)
- For example in order to encrypt the database connections (via SSL)
2. The database connection (UDL file) has been recently changed (for example renamed) but the manual ODBC connection has not been modified (created or renamed).

For more information, see separate IBM Technote #2016886.

  • Scenario #7 - Incorrect %PATH% system variable (when using encrypted DB2 connections) on application server
    • For more information, see separate IBM Technote #0717291.
  • Scenario #8 - The COM+ user (the username used to run the COM+ application) does not have sufficient rights to use the Oracle client.
    • For more information, see separate IBM Technote #1106979.

Environment

Scenario #1 - Application server running Windows 2003 SP2.

Diagnosing The Problem

Scenario #1
For example, in one real-life scenario when opening the registry section 'HKLM\Software\odbc\odbcinst.ini\odbc drivers', there was no entry for 'SQL Server'.

  • See attached documents "Good_server.jpg" and "Bad_Server.jpg" for printscreen examples.

Resolving The Problem

Scenario #1
Install/re-register the database driver correctly onto the Controller application server.

Examples:
Below is a table for the most popular drivers:

Database server
Provider
Installation instructions
SQL 2005
SQLNCLI.1
Download from Microsoft and install SQL 2005 Native Client ("sqlncli.msi")
SQL 2008
SQLNCLI10.1
Download from Microsoft and install SQL 2008 Native Client ("sqlncli.msi")
SQL 2012
SQLNCLI11.1
Download from Microsoft and install SQL 2012 Native Client ("sqlncli.msi")
SQL 2014
SQLNCLI11.1
Download from Microsoft and install SQL 2012 Native Client ("sqlncli.msi")
SQL 2016
SQLNCLI11.1
Download from Microsoft and install SQL 2012 Native Client ("sqlncli.msi")
SQL 2017 SQLNCLI11.1 Download from Microsoft and install SQL 2012 Native Client ("sqlncli.msi")
 
TIPS:
  • Microsoft no longer produce a new native client for versions of SQL from SQL 2014 onwards.
    • For more details, see Microsoft link below.
  • The above files can be downloaded from Microsoft
  • At the time of writing (December 2019) the latest version of the SQL Server Native Client (sqlncli.msi), can be downloaded from the Microsoft® SQL Server® 2012 Feature Pack page (link below)


Scenario #2
Modify a registry key on the Controller application server, so that the value is the English translation.

  • For more information, see separate IBM Technote #1370908.

Scenario #3
Upgrade to Controller 8.5.1 (8.5.1414) or later.

  • For more information, see separate IBM Technote #1430066.

  

Scenario #4

Install Oracle 10G rel2 client correctly on Controller Application server.

  • For more information, see separate IBM Technote #1347585.

  

Scenario #5
Upgrade to Controller 10.2.0 or later.

  • For more details, see separate IBM Technote #1962603.

    

Scenario #6

Update (create/rename) the relevant 32-bit ODBC connection.

  • For more details, see separate IBM Technote #2016886.

Scenario #7

Modify the %PATH% system variable on the Controller application server.

  • For more details, see separate IBM Technote #0717291.

Scenario #8

In some (rare) environments, the COM+ user must be changed to be the application server's local Windows user 'administrator'.
  • For example:      servername\administrator
  • For more details, see separate IBM Technote #1106979.

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Historical Number

1038736

Document Information

Modified date:
20 December 2019

UID

swg21347737