Troubleshooting
Problem
Client PC is part of a workgroup and he is trying to use Office connection installed on a computer which is part of a domain. Cognos environment has SSO enabled and the end user is prompted for his login ( network login ) when he tries to connect to office connection. After putting credentials , office connection hangs and following error is displayed.
Symptom
The remote server returned an error: (401) Unauthorized
System.Net.WebException : The remote server returned an error:( 401) Unauthorized.
at Sytem.Net.HttpWebRequest.GetResponse()
at Cognos.Office.Framework.Communication.DataSource.GetCAFContextId()
at Cognos.Office.Framework.Communication.DataSource.Logon()
at Cognos.Office.Framework.UI.Toolbars.UIToolbar.Logon(String Key)
Cause
Computer trying to connect to Office connection was part of workgroup
Environment
Windows, IIS 6.0
Resolving The Problem
Configure the computer to be part of same domian as Cognos server .
Steps:1. First login to server where Cognos is installed , Right click on 'My computer' on dektop and click on 'Properties'2. Click on 'Computer Name' tab and note the domain name ; ex: test.cognos.com
3. Login to the computer having problem and open the 'My computer' properties, click on 'computer name' and it should display that computer is part of a workgroup.
4. Click on 'Change' button, and choose 'Domain' and type the domian name retrieve from step 1-2 and click ok, close all the windows and restart your computer and make sure you choose the domain when logging on to windows.
Historical Number
1038683
Was this topic helpful?
Document Information
Modified date:
14 October 2022
UID
swg21347724