IBM Support

Nothing appears after clicking on button for Intercompany Details.

Troubleshooting


Problem

User launches 'Company' - 'Data Entry - Reported Values'. User selects a data entry form which relates to intercompany (IC) information. Excel opens. User clicks on the 'Intercompany Details' icon/button (on the left hand side) on the toolbar. As expected, this launches a new Windows 'Intercompany Details'. Unfortunately, this is 'minimised' and user cannot bring this window to the foreground by clicking on it.

Symptom

Example:



In other words, Excel *appears* to freeze when clicking on the button for Intercompany Details.

There is no error message.

Cause

During the previous Controller session, the end user has moved/resized the 'Intercompany Details' window to a location which is currently unviewable.

  • In other words, the previous location/size is impossible for the current monitor to display.

More Information:
Controller remembers the size/position of several of its screens.
  • The size and position for the 'Intercompany Details' window is stored inside the file CCR.CONFIG, inside the user's Windows profile (%appdata%\cognos\ccr\ccr.config).

For example, a typical sized window may have values similar to the following:
    <add key="frmDErepvalICMpopup-Left" value="2160" />
    <add key="frmDErepvalICMpopup-Top" value="2340" />
    <add key="frmDErepvalICMpopup-Width" value="9345" />
    <add key="frmDErepvalICMpopup-Height" value="6675" />

If the user has somehow moved/resized this window to an unviewable location/size, then the user will not be able to see it.

Environment

Typically this problem occurs when the user changes their display size, for example:

  • Scenario #1 - User changes from a larger external monitor to their smaller laptop screen (or vice-versa)
  • Scenario #2 - User sometimes works with two monitors (two screens), and the problem gets triggered when the user changes to only using one screen.

Diagnosing The Problem

TIP: For more information relevant to when using Citrix, see separate IBM Technote #1672412.

Resolving The Problem

Long-term Fix:
Modify the 'bad' end user's settings, so that it stops Controller from remembering screen positions

  • In other words, for this 'bad' user only (per user setting) Controller will no longer remember/save the location/size of Windows positions.

Steps:
Each individual user should do the following:
1. Click "Maintain / User / Personal Defaults > tab Layout (2)"
2. Untick the box 'Save Window Size':

3. Click Save
4. Logoff from Controller, and re-launch the Controller client.

===================================================
NOTE: The above 'Save Windows Size' change is stored inside the database, inside the 'xconfig' table. It is recorded separately for each individual user:
Therefore:
  • Each end user must make this change separately
  • They must repeat the change for each separate database that they use (for example 'production', 'test' and so on).
===================================================

Workaround #1
Modify the settings (inside the end user's CCR.CONFIG file, located in their Windows user profile).

Steps:
  1. Logon to the client device (for example the end user's PC) using the 'bad' end user's Windows username
  2. Click 'START - RUN'
  3. NOTEPAD %appdata%\Cognos\CCR\CCR.config <Enter>
  4. Search for 'frmDErepvalICMpopup'
  5. Modify the values to the following:
<add key="frmDErepvalICMpopup-Left" value="2160" />
<add key="frmDErepvalICMpopup-Top" value="2340" />
<add key="frmDErepvalICMpopup-Width" value="9345" />
<add key="frmDErepvalICMpopup-Height" value="6675" />

6. Save file, and then test.

Workaround #2 (only works in some environments)
Right-click on the 'Intercompany Details' icon (on the Windows taskbar) and choose 'Maximise'.

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.1;10.2.0;10.1.1;10.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Historical Number

1038139

Document Information

Modified date:
15 June 2018

UID

swg21347666